Cisco ISRg2 Router

Hier werden Themen rund um Hardware behandelt, die man für einen Telefon- oder Internetanschluss benötigt.
Du findest als Unterordner auch ein Spezialforum, wo es sich nur um die AVM-FritzBox dreht.
Antworten
nilsstorm

Cisco ISRg2 Router

Beitrag von nilsstorm » 30. Okt 2013 14:05

Hallo,

ich bin gerade dabei eine Config für einen Cisco ISRg2 1941 zu schreiben und würde gerne wissen ob es so etwas wie eine Optimal Config für das Dialer Interface gibt? :?: :?: :?:

Der Router wird an einem Willy.Tel Anschluss stecken, 100.000kbit/s Down.- und 20.000kbit/s Upload.

Vielen Dank im Voraus.

Nils Storm

Net Killer:-)

Re: Cisco ISRg2 Router

Beitrag von Net Killer:-) » 30. Okt 2013 15:45

Ist zwar von einer 871, sollte aber egal sein. IOS ist schliesslich IOS ;)

Code: Alles auswählen

interface FastEthernet0
 description LAN-VLAN1
!
interface FastEthernet4
 description Uplink-PPP
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Vlan1
 description LAN-Logical
 ip address 172.25.0.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip tcp adjust-mss 1452
!
interface Dialer1
 description Uplink-PPP
 mtu 1492
 bandwidth 100000
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp pap sent-username <UserName> password <Password>
!
ip route 0.0.0.0 0.0.0.0 dialer1
Sollte so zumindest passen, ist auswendig runtergetippt :D
Interfaces musst ggf. anpassen. MTU 1492 bei aktivem MSS Clamping auf 1452 sollte bei WT ebenfalls passen (trotz L2TP im Backbone)

nilsstorm

Re: Cisco ISRg2 Router

Beitrag von nilsstorm » 31. Okt 2013 08:28

Danke.

nilsstorm

Re: Cisco ISRg2 Router

Beitrag von nilsstorm » 19. Dez 2013 21:37

Moin,

muss auf dem Dialer Interface noch DNS konfiguriert werden?

ppp ipcp dns request accept
ppp ipcp wins request accept

Und was muss noch alles in der Config stehen damit es von Provider Seite passt?

Net Killer:-)

Re: Cisco ISRg2 Router

Beitrag von Net Killer:-) » 20. Dez 2013 00:02

jein .. MUSS nicht
auf dem dialer brauchst ja kein dns.
einfach im dhcp pool statisch einen verteilen. interessiert ja nur den client

nilsstorm

Re: Cisco ISRg2 Router

Beitrag von nilsstorm » 21. Dez 2013 20:21

Moin,

was ist denn sinnvoller? Momentan sieht die config so aus:

Code: Alles auswählen

Router1941#sh run
Building configuration...
!
...
!
ip dhcp pool 16 ! für DMZ
 network 176.16.2.0 255.255.255.0
 domain-name XXXXXXXX
 dns-server 176.16.2.1 
 netbios-name-server 176.16.2.1 
 default-router 176.16.2.1 
 netbios-node-type h-node
!
!
ip domain name XXXXXXXX.home.com
ip host Switch3560-1 192.168.XX.XX
ip host Router1941 192.168.250.1
ip ddns update method DYNDNS
 HTTP
  add https://XXXXXXXX:XXXXXXXX@members.dyndns.org/nic/updatesystem=dyndns&hostname=hostname.dyndns.org&myip=<a>
 interval maximum 0 1 0 0
!
!
...
!
crypto pki trustpoint DYNDNS-EQUIFAX
 enrollment terminal pem
 revocation-check none
!
crypto pki certificate chain DYNDNS-EQUIFAX
 certificate ca 35DEF4CF
  30820320 ...
!
interface GigabitEthernet0/0
 description Uplink zu WillyTel
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
 description to Switch3560-1 L3
 mtu 9000
 ip address 192.168.11.2 255.255.255.0
 duplex auto
 speed auto
!
!
interface Dialer1
 description Uplink-PPPoE zu WillyTel
 mtu 1492
 bandwidth 100000
 ip ddns update hostname XXXXXXXX.dyndns.org
 ip ddns update DYNDNS
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp pap sent-username XXXXXXXX password 7 XXXXXXXX
 ppp ipcp dns request accept
 ppp ipcp wins request accept
 no cdp enable
!
!
router eigrp 1
 default-metric 10000 1 255 1 1500
 network 176.16.2.0 0.0.0.255
 network 192.168.250.0 0.0.0.3
 redistribute static
!
...
!
ip dns server
ip nat inside source list NAT-OUT-ACL interface Dialer1 overload
ip nat inside source static tcp 176.16.2.XX 21 interface Dialer1 21
ip nat inside source static tcp 176.16.2.XX 443 interface Dialer1 443
ip nat inside source static tcp 192.168.21.XX 5060 interface Dialer1 5060
ip nat inside source static udp 192.168.21.XX 5060 interface Dialer1 5060
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended NAT-OUT-ACL
 deny   ip 192.168.21.0 0.0.0.255 192.168.0.0 0.0.7.255
 deny   ip 192.168.11.0 0.0.0.255 192.168.0.0 0.0.7.255
 permit ip any any
!
Zone Based Firewall, QoS und VPN lasse ich jetzt mal aussen vor.

DHCP für das LAN wir von einem 3560CG Switch bereitgestellt, an den die Hosts direkt angeschlossen sind. Dieser ist dann über einen geroutetes Interface an den Router angeschlossen.

Net Killer:-)

Re: Cisco ISRg2 Router

Beitrag von Net Killer:-) » 22. Dez 2013 13:31

Das hängt auch vom restlichen Setup ab.
Wenns Windows Host in einer Domäne sind, hast du ja einen internen DNS. Den würde ich dann logischerweise auch verteilen lassen. Externe Auflösung dann via DNS Forwarder auf dem internen DNS.

Du musst in deinem Fall natürlich auch DNS dem Router selbst bekannt machen, damit der die DynDNS Anfrage überhaupt auflösen kann.

Viele Wege führen nach Rom ;)

nilsstorm

Re: Cisco ISRg2 Router

Beitrag von nilsstorm » 30. Dez 2013 00:53

Moin,

also mein Netzwerk setup eigentlich recht simpel, der Router soll lokaler DNS Server für das Netzwerk sein. An den Router direkt angeschlossen ist die DMZ, in der FTP und Webserver laufen (FreeBSD). Vom Router gibt es eine Layer 3 Verbindung zu einem Cisco C3560CG Switch an dem meine LAN Geräte angeschlossen sind (Mac OS X, IOS und FreeBSD), ab und an kommt auch mal ein Windows Laptop zu besuch. DHCP für das LAN wird von dem Cisco 3560 Switch bereitgestellt.

So würde ein manuelles Setup aussehen aber Dynamisch währe mir lieber.

Code: Alles auswählen

ip dns view XXXXX.home.com
 domain list XXXXX.home.com
 domain name-server 176.16.2.1      ! DMZ DNS server
 domain name-server 192.168.250.1   ! LAN DNS server
 domain resolver source-interface gi0/1
 domain round-robin
 dns forwarder 176.16.2.1           ! DMZ DNS server 
 dns forwarder 192.168.250.1        ! LAN DNS server
 dns forwarding source-interface gi0/1
!
ip dns view default
 domain timeout 1
 domain resolver source-interface dialer 1
 dns forwarder 213.209.104.220       ! public DNS servers
 dns forwarder 213.209.104.250       ! public DNS servers
 dns forwarding source-interface dialer 1

Antworten