Packetloss / Latenzen / Routing

Spezielle technische Fragen zum Thema Internet über TV-Kabelanschluss? Dann bist Du hier richtig!
Antworten
Net Killer:-)

Packetloss / Latenzen / Routing

Beitrag von Net Killer:-) » 3. Nov 2008 10:03

also ich hab nu das ganze we zu verschiedenen zeiten gecheckt und hatte nicht ein einziges problem.

weder beim wow zocken, noch beim connect auf meinen teamspeak server hatte ich packetloss.
insbesondere da es we war, wage ich zu behaupten, dass die probleme die mich zur eröffnung dieses threads bewogen haben nicht mehr existieren.

wichtig an dieser stelle an alle die jetzt noch störungen haben: nur weil ein thread dazu existiert heisst das nicht, dass eure probleme daher kommen. nicht einfach blind tests (und deren aussagen) übernehmen, wenn ihr nicht ganz genau wisst was ihr da eigentlich macht. auch wenns arrogant klingt: wenn ich nen traceroute poste, dann weiss ich auch welche aussagegenauigkeit dieser hat und habe diesen trace auf verschiedenste weisen gegengeprüft. das finden (und im backbone meines arbeitgebers beheben) von backboneproblemen ist mein täglicher job. damit verdiene ich mein geld, daher kann ich von mir sagen "ich weiss zu 100% was ich da tue". wenn ich mir so einige postings hier durchlese, dann kann das bei weitem nicht jeder von sich behaupten.

das ist nicht weiter schlimm. schliesslich ist es eine recht komplexe und schwierige thematik. lasst euch nur einfach nicht dazu hinreissen eure probleme mit denen dieses threads zwingend gleichsetzen zu wollen. trifft nämlich nicht bei jedem zu!

Dirty Harry

Re: Packetloss / Latenzen / Routing

Beitrag von Dirty Harry » 3. Nov 2008 23:46

Net Killer:-) hat geschrieben:also ich hab nu das ganze we zu verschiedenen zeiten gecheckt und hatte nicht ein einziges problem.

weder beim wow zocken, noch beim connect auf meinen teamspeak server hatte ich packetloss.
insbesondere da es Wochenende war, wage ich zu behaupten, dass die probleme die mich zur eröffnung dieses threads bewogen haben nicht mehr existieren.

wichtig an dieser stelle an alle die jetzt noch störungen haben: nur weil ein thread dazu existiert heisst das nicht, dass eure probleme daher kommen. nicht einfach blind tests (und deren aussagen) übernehmen,
Wilhelm.tel hat in der Nacht vom 28. auf den 29. Okt 2008 einiges an Hardware (Server etc.) ausgewechselt, die an ihrer Leistungsgrenze war.
Damit dürften die meisten im "Packetloss/Latenz"-Thread beschriebenen Phänomene beseitigt worden sein.
Bei Tests von mir und Net Killer sind derzeit keine Probleme mehr feststellbar, andere Mitglieder bestätigten diese Ergebnisse.
Sollte doch noch jemand irgendwelche Schwierigkeiten haben, so soll er bitte das ServiceCenter anrufen,
da es sich dann höchstwahrscheinlich um ein Einzelproblem handelt. Dieses kann hier mit allgemeinen Ratschlägen von uns nicht behoben werden,
da müßte dann ein Techniker "vor Ort werkeln". Ich wäre sehr dankbar wenn Ihr Euch an diese Bitte halten würdet und hier nicht stur weiterposten würdet.
Danke !

Da das Thema sich vorerst erledigt hat, habe ich den Thread geteilt und den Rattenschwanz verschoben.

Viele Grüße,
Dirty Harry

reaper

Re: Packetloss / Latenzen / Routing

Beitrag von reaper » 4. Nov 2008 09:40

hier sind nochmal die statments von router-freak und master zu diesem thema:
router-freak hat geschrieben:Hi,
das einige Router Packet-Loss haben ist völlig normal und sagt nichts über die Routing-Perfomance aus ! Um den Routing-Prozessor vor den Massen an Traceroutepaketen zu schützen, ist ein Queue vorgeschaltet, die nur eine Gewisse Anzahl an Bandbreite zum Prozessor durchlässt.
Das Entscheidene ist immer das Ziel, wenn da kein Packetloss auftritt ist alles in Ordnung ... egal was die Router dazwischen meinen.

Die Router haben als Priorität 1 das Routen von Paketen, dann die Kommunikation der Routingprotokolle und ganz zum Schluß die Antwort auf Pings und Traceroutes ...
Viele Provider gehen auch langsam dazu über die Traceroute komplett zu blocken, das sind dann die Router die 100% Packetloss haben, aber das Ziel trotzdem noch erreichbar ist ;-)
Auch die Antwortzeiten der einzelnen Router können nur ein groben Schluß auf die Auslastung des Router geben, weil das wie oben geschrieben alles nur nachrangig behandelt wird.
Und zu guter letzt können die Zeiten auch stark schwanken, weil jeder Routing-Hop eine andere Rückroute zu wt haben kann. Aber wen es wirklich interessiert, der sollte sich mal mit dem Tracroute beschäftigen, da gibts im I-Net genug Abhandlungen drüber. Und dann sieht man die Zahlen in einem ganz anderen Licht.
Die meisten Traceroutes die ich zu sehen bekomme zeigen eigentlich keine Probleme auf ;-)

Die Probleme die bei wt aufgetreten sind lagen an den alten Cisco-Routern, die waren einfach an der Last-Grenze. wt hat in den letzten Wochen den kompletten Backbone auf 10GBit Leitungen umgestellt, die Kompletten Core-Switche wurden ausgetauscht und nun zum Schluß waren auch noch die Router dran. Also es passiert grad eine ganze Menge und die Umbauten sind auch noch lange nicht erledig. Als nächstes wird ein zusätzliche Austauschpunkt in Hamburg angebunden, wo es dann zusätzlich Leitungen ins Internet geben wird. Die B-RAS-Systeme für die PPPOE-Einwahl werden auch demnächst erneuert.

Also es tut sich was ....

cu router-freak
master hat geschrieben:Hallo,
also wie Router-Freak schon geschrieben hat =
Es ist völlig egal wie viel PL ( Paket-Lost ) ihr auf dem Main3 habt! Entscheidend ist wie viel Pakete zum Ziel verloren gehen!

[...]

Die Main Router haben einen Filter die einfach gesprochen das ICMP Sperren! Der soll Routen und Pakete weiter Leiten, nicht auf PINGs antworten.
Daher resultieren die PL.
Das sagt nichts über die Performance des Routers aus.

Ein Router schiebt die Datenpakete in Hardware durch seine Interface. PINGs und der gleichen muß ein Router über seine CPU fahren.
Die CPU aber wiederum muß vor übermäßigen ICPM u.s.w. geschützt werden da es sonst ganz einfach währe z.b. durch eine DOS Attacke den Router so in die Knie zu zwingen das er seine Aufgaben nicht mehr erledigen kann.
Daher bearbeitet ein Router ICMP die an ihn gerichtet sind mit ganz niedriger Priorität, b.z.w. verwirft er einfach diese Pakete.

Wenn am Ziel PL auftritt ist es ein Netz Problem!.
In Net Killer Trace in das WT Netz vor Umstellung kann man es gut sehen:

Code: Alles auswählen

7. te4-1.ccr01.ham01.atlas.cogentco.com                                                                                   0.0%   139   20.2  23.2  19.0 177.7  18.6
8. wtnet.demarc.cogentco.com                                                                                              0.0%   139   19.7 101.6  15.9 1651. 277.2
9. 213.209.104.54                                                                                                        12.9%   139   27.7  25.2  17.1  35.7   3.7
10. cmts-pop-12.routing.wtnet.de                                                                                           7.2%   139   21.4  19.2  17.0  22.8   1.3
11. pop12-938.catv.wtnet.de                                                                                               13.7%   139   52.7  63.1  43.6  89.3   9.5
Das war vor der Umstellung auf die Neuen Router! Hier sieht man gut den PL auf das Ziel! Das war ein Problem.

[...]

Gruß
Master

mETz

Re: Packetloss / Latenzen / Routing

Beitrag von mETz » 4. Nov 2008 10:47

Dirty Harry hat geschrieben:Da das Thema sich vorerst erledigt hat, habe ich den Thread geteilt und den Rattenschwanz verschoben.
Du meinst wohl 90% der Antworten gelöscht :P Sorry aber ihr könnt hier nicht einfach einen Thread komplett umkrempeln und alle bisherigen Beiträge ins Nirvana verschieben. Wenn es um einen neu geordneten und damit übersichtlicheren Thread geht, dann legt den halt als neuen Thread an und verweist im letzten Posting des "Chaosthreads" auf den neuen und schließt dabei den alten Thread.

Diese Postinglöscherei kotzt mich echt langsam an!

madmonkey

Re: Packetloss / Latenzen / Routing

Beitrag von madmonkey » 4. Nov 2008 19:01

So, verloren gegangener Thread wieder...
Drum habe ich diesen Beitrag aufs wesentliche zurückeditiert.
So fair sollten dann auch die anderen sein...

01.10.2008 - 26.10.2008 nicht protokollierte, ZAHLREICHE Probleme (ca jeden 2 Tag Probs wie unten beschrieben)
27.10.2008 19.26h für 15 min Internet komplett weg (restlich zeit :TS2 : kann andere relativ gut verstehen aber mich hören alle nur abgehackt, PL bei TS2 - 79%)
28.10.2008 15.58h für 2 min kein internet, TS geht, aber ganzen nachmittag sehr laggy trotz PL bei TS2 2%
02.11.2008 13.00h dods laggy aber noch spielbar, wenn auch sehr bescheiden, TS2 relativ gut, aber nicht akzeptabel. (verständigung gerade so möglich)
02.11.2008 15.23h - 01.30h und länger dods unspielbar, TS2 geht recht gut, PL bei TS2 0,75% aber nicht akzeptabel.
03.11.2008 13.00h kurzer Test, scheint alles wieder in ordnung zu sein
04.11.2008 18.00h scheint alles in Ordnung
05.11.2008 16.00h scheint alles in Ordnung
Zuletzt geändert von madmonkey am 5. Nov 2008 16:00, insgesamt 1-mal geändert.

Net Killer:-)

Re: Packetloss / Latenzen / Routing

Beitrag von Net Killer:-) » 4. Nov 2008 20:00

Deine Störungen werden wohl mit dem Wechsel von der 5 auf die 30 mbit Leitung zusammen hängen. Evtl. ist deine Leitung nicht 100% sauber (die Scientific Modems scheinen deutlich empfindlicher zu sein als die Motorolas). Wird also wohl nix mit der allgemeinen Routingproblematik (die im übrigen bei mir weiterhin nicht erneut aufgetreten ist), welche durch den Hardwaretausch behoben wurde nix zu tun haben.

So oder so: Nicht alles was so aussieht ist ein Vergleich. Was deinen zu 1945 angeht ist das nen absoluter Schuss in Kopf. Schuldidung, aber damit stellst du dich absolut ins aus. Sauer sein kann jeder, keine Frage aber diese Art der Argumentation ist einfach unter aller Gürtellinie.

Der Ursprungsthread ist nicht gelöscht, sondern in nem nicht öffentlichen Forenbereich. Warum entzieht sich meine Kenntnis, finde ich persönlich auch nicht absolut sinnvoll.

Im übrigen: Bevor hier jemand Zensur schreit, bitte einmal informieren was Zensur ist. Nämlich das verbieten einer Veröffentlichung. Wenn also im Nachhinein etwas gelöscht wird, ist es bereits veröffentlicht gewesen und kann daher keine Zensur mehr sein. Sich über Wortbedeutungen zu streiten ist aber Kinderkram.

Dirty Harry

Re: Packetloss / Latenzen / Routing

Beitrag von Dirty Harry » 4. Nov 2008 23:31

Tja, ich sage immer:
"Gut gemeint" ist eine andere Ausdrucksform für "schlecht gemacht"
Vielleicht hat mich das hier eingeholt :mrgreen: , vielleicht auch nicht. Wer weiß das ganz genau. :smt017

Ich hatte - und habe noch - den Eindruck, daß das eigentliche Problem inzwischen beseitigt wurde.
Das bedeutet nicht, daß es nicht noch vereinzelte Kunden geben kann, bei denen aufgrund besonderer Bedingungen
in ihrem speziellen Fall, weitere Maßnahmen nötig sind.
Das sind dann aber Einzelfälle, keine grundsätzliche Problematik die viele oder gar alle Kunden betrifft.
Wenn hier jedoch einige Kunden (gilt nicht für alle) von Verzögerungen, Paketverlust oder Zugangsproblemen lesen,
dann schreien sie sofort los: "Ich habe auch Probleme, ist doch klar, Tatsache XYZ ist Schuld, genau wie bei den anderen auch."
Da wird dann oftmals gar nicht mehr geprüft ob da wirklich eine echte Störung bei einem selbst vorliegt,
geschweige denn ob sie auf den gleichen Ursachen beruht wie bei dem einen oder anderen Kunden, der hier von seinem Fall berichtet.
Da steigern sich manche richtig in eine fixe Idee hinein, das bei ihnen etwas im Argen liegen MUß, schließlich schreiben so viele andere ja auch davon.
So etwas weitet sich zum Teil ganz schön aus... .

Um nun, nach Beseitigungs des allgemeinen Leistungsproblems durch WT, die "Bei mir auch" - Hysterie abzumildern,
hatte ich die inzwischen irrelevant gewordenen Anfangsbeiträge abgetrennt und in eine Art Zwischenlager verschoben.
Dort heraus kann Master den Threadanfang jederzeit herausholen und wieder in Situ setzen. So er es denn für sinnvoll hält.

Zum Vorwurf, ich würde hier etwas vertuschen wollen:
1.) Da ist nichts. Folglich kann man auch nichts vertuschen.
2.) Ich war einer der schärfsten Kritiker von WT und den Stadtwerken und dürfte so einige Leute dieser Unternehmen mit meinen Äußerungen
zur Weißglut getrieben haben... . Das war aber zu einem Zeitpunkt, als da auch ein Paar Sachen in meinen Augen ziemlich, hmm, "unsauber" liefen.
Also werft mir nicht vor, ich würde etwas vertuschen wollen, wenn denn etwas vorliegen würde. Das ist einfach Quatsch.
3.) Vermutet doch nicht gleich eine Verschwörung oder fühlt Euch persönlich angegriffen wenn alte Beiträge verschoben/gelöscht werden.
Ich kann ja verstehen, daß man sich sehr daran stört, wenn man als Einzelner aus einer laufenden Diskussion "herausgeschnitten" wird,
einem also die Stellungnahme unmöglich gemacht wird. Aber da war hier ja gar nicht der Fall.
Jeder hatte seinen Teil sagen können, jeder hat es gelesen, jeder konnte auf die Erwiderung erneut antworten.
Nur, das war inzwischen Schnee von gestern. Und aus den Beiträgen konnte auch keiner etwas lernen oder hilfreiche Tips ziehen,
denn darin standen nur Zustandsbeschreibungen von verschiedenen Einzelanschlüssen die aufgrund eines inzwischen behobenen Problems abgegeben worden waren.
Sie hätten nur dazu führen können, daß weitere Kunden irritiert worden wären und anfangen bei sich Störungen zu suchen, die gar nicht da sind (weil andere ja auch Probleme haben) und das immer so weiter geht.

Gruß,
Dirty Harry

mETz

Re: Packetloss / Latenzen / Routing

Beitrag von mETz » 5. Nov 2008 00:09

Dirty Harry hat geschrieben: Um nun, nach Beseitigungs des allgemeinen Leistungsproblems durch WT, die "Bei mir auch" - Hysterie abzumildern,
hatte ich die inzwischen irrelevant gewordenen Anfangsbeiträge abgetrennt und in eine Art Zwischenlager verschoben.
Dort heraus kann Master den Threadanfang jederzeit herausholen und wieder in Situ setzen. So er es denn für sinnvoll hält.
Schön, dann können wir in Zukunft ja jeden Thread dessen Problem beseitigt wurde löschen :P Sorry aber so benutzt man kein Forum, daher werde ich mich jetzt auch bis auf weiteres abmelden (löschen geht ja beim phpBB leider nicht).

reaper

Re: Packetloss / Latenzen / Routing

Beitrag von reaper » 5. Nov 2008 08:53

ein einfaches schliessen des threads hätts auch getan. subject umbenennen in "blah blah [ERLEDIGT]" und gut is. war doch klar, dass sich hier viele wundern warum der thread plötzlich weg ist. ich habs auch nicht ganz verstanden. deswegen hab ich die beiden wichtigsten posts hier nachträglich nochmal eingefügt.

madmonkey

Re: Packetloss / Latenzen / Routing

Beitrag von madmonkey » 5. Nov 2008 16:07

So, meinen obigen beitrag hab ich zurückeditiert.

Wie gesagt, WT braucht sich nicht zu verstecken, und bleibt, auch wenns mal Probs gibt, ein klasse anbieter...
Auch wenn man mal stinksauer reagiert ;)


Was ich allerdings eher zu bemänglen habe ist :
Das es ja anscheinend benkannte Hardware probleme gab,
diesbezüglich aber im Forum "Störungen" keine offiziellen angaben gemacht worden sind.
Oder Generell, wenn bekannt ist das es bei euch Probleme gibt, es einfach mal dort zu Posten...

Ich hatte den ganzen Oktober immer mal dieder bei Störungen geschaut, nix gefunden, und war natürlich umso verärgerter, das es trotz des 5 seiten Threads immer noch keine Bekanntgabe dazu gab....
Und sei es nur ne aussage wie :
Es ist bekannt das es Problem xxx gibt und wir arbeiten drann.
(vielleicht dann nochmal die ein oder andere Altualisierung was geschah oder ob es Lokalisiert worden ist)
Dann wären bestimmt viele Kunden beruhigter und hätten keinen Herzanfall bekommen)

Dirty Harry

Re: Packetloss / Latenzen / Routing

Beitrag von Dirty Harry » 5. Nov 2008 17:49

Nun, lieber madmonkey,

diesen frommen Wunsch nach einer Benachrichtigung über Beeinträchtigungen im WT-Netz
haben wir "alten Hasen" schon 1000 mal von anderen Kunden gehört und selber bereits 100 mal geäußert.
Ich verweise dazu auf meinen letzten Thread zu dieser Frage : viewtopic.php?f=11&t=3298&p=30256&hilit ... ung#p30256

Immerhin hat man daraufhin die Rubrik "Störungen/Wartungen" eingerichtet, was ich als ganz großen Fortschritt ansehe.
Es wurden dort auch wiederholt Meldungen eingestellt, die jetzt jedoch nicht mehr sichtbar sind.
(Nach einer gewissen Zeit sind diese Nachrichten überholt und werden vom Board automatisch entfernt)
Bei dem aktuellen Fall hätte man dort wohl eher eine Information einstellen sollen. Und zusätzlich einen dauerhaften
Thread erstellen, der über den Austausch der Hardware aufklärt, einschließlich aller daraus resultierenden Vor- u. Nachteile.
Hätte. Hat man aber nicht. Leider.
Es sind zuwenig echte "WT-Insider" hier aktiv ( nur master und it-fred ) und die haben offensichtlich viel zu viele andere
Dinge zu tun, die sie als wichtiger einschätzen. Das ist nun einmal so :smt022 , seien wir froh, daß wir überhaupt diese Kommunikationsplattform haben.
Ohne Masters Alleingang seinerzeit gäbe es sicherlich noch heute nicht dieses Board.

Gruß,
Dirty Harry


PS:
Ich finde es gut, daß Du Deinen Beitrag bereinigt hast. Aber lassen wir die alten Kamellen ruhen, es sollte jetzt nicht jeder seine ganzen "Entgleisungen" beseitigen.
Das macht unnötige Arbeit und schafft unter Umständen sogar neue Verwirrung/Unstimmigkeiten. Und so schlimm war das alles ja gar nicht. :smt052

Antworten